Friday, 2 May 2014

belief systems and their harm

If any belief system, whether secular or religious, sets out to do any of the following, I consider it bad for humankind:

a) It advocates harm to others, either as punishment or for merely disagreeing with it;
b) It is not based on empirical observation;
c) It claims that other belief systems are false on purely stated/a priori grounds, rather than empirical grounds (e.g. that they make no regular predictions).

I believe this list of criteria, if practiced, will solve humanity's problems. However, people are far too fond of doing the opposite:

a) Advocating harm to those who disagree or who do wrong as decided in an arbitrary set of rules;
b) Base things on what their parents or other elders told them;
c) Love stating that others are in moral or spiritual jeopardy for failing to recognise the legitimacy of the system, rather than on empirical (visible/measurable) grounds;

Moreover, I believe that any system which has the following requirements is inherently a cult and bad for humanity (whether a "scientific" system or a "spiritual" system:

a) It says that it is forbidden to question the leader(s) or belief system that they espouse;
b) it prohibits rejection of the system once it is accepted as "true"
c) it has special behavioural requirements such as dress or other visible markers to distinguish its practitioners as being "special" or "in touch with" some "higher" truth claims.

installing apache apr on tomcat


get apr from http://apr.apache.org
tar zxvf apr-1.4.2.tar.gz
./configure

make
make test (not necessary)
make install
(puts the files into /usr/local/apr)

yum install apr-devel openssl-devel

cd /usr/local/tomcat/bin
tar zxvf tomcat-native.tar.gz
cd tomcat-native-1.1.16-src
cd jni/native

./configure --with-apr=/usr/local/apr/ --with-java-home=$JAVA_HOME --prefix=$CATALINA_HOME --with-ssl=yes 

make
make install

cp .libs/libtcnative-1.* /usr/lib/java-latest/

make sure that the soft link is also copied, if not:
ln -s libtcnative-1.dylib  libtcnative-1.jnilib

make sure you do the below or it cannot find APR
vim /etc/profile.d/java.sh
LD_LIBRARY_PATH=/usr/local/tomcat/lib:$LD_LIBRARY_PATH/usr/local/apr/lib
export LD_LIBRARY_PATH

you will also need apr-utils

so download from same page

cd into apr-utils src dir
./configure --with-apr=/usr/local/apr/ --with-ldap

then 
make
make install

Restart tomcat.

php 7 nightmare

OK so Centos 6 insists on installing php 5.3 and even if you download other RPMs and install them, they do not replace the existing 5.3 whic...